Skip to content
Navigation Menu
Sign in
Appearance settings
Platform
AI CODE CREATION
GitHub Copilot
Write better code with AI
GitHub Copilot app
Direct agents from issue to merge
MCP Registry
Integrate external tools
DEVELOPER WORKFLOWS
Actions
Automate any workflow
Codespaces
Instant dev environments
Issues
Plan and track work
Code Review
Manage code changes
Code Quality
Enforce quality at merge
APPLICATION SECURITY
GitHub Advanced Security
Find and fix vulnerabilities
Code security
Secure your code as you build
Secret protection
Stop leaks before they start
EXPLORE
Why GitHub
Documentation
Blog
Changelog
Marketplace
View all features
Solutions
BY COMPANY SIZE
Enterprises
Small and medium teams
Startups
Nonprofits
BY USE CASE
App Modernization
DevSecOps
DevOps
CI/CD
View all use cases
BY INDUSTRY
Healthcare
Financial services
Manufacturing
Government
See all industries
View all solutions
Resources
EXPLORE BY TOPIC
AI
Software Development
DevOps
Security
View all topics
EXPLORE BY TYPE
Customer stories
Events & webinars
Ebooks & reports
Business insights
GitHub Skills
SUPPORT & SERVICES
Documentation
Customer support
Community forum
Trust center
Partners
View all resources
Open Source
COMMUNITY
GitHub Sponsors
Fund open source developers
PROGRAMS
Security Lab
Maintainer Community
GitHub Stars
Archive Program
REPOSITORIES
Topics
Trending
Collections
Enterprise
ENTERPRISE SOLUTIONS
Enterprise platform
AI-powered developer platform
AVAILABLE ADD-ONS
GitHub Advanced Security
Enterprise-grade security features
Copilot for Business
Enterprise-grade AI features
Premium Support
Enterprise-grade 24/7 support
Pricing
Search
/
Sign in
Sign up
Appearance settings
You signed in with another tab or window.
Reload
to refresh your session.
You signed out in another tab or window.
Reload
to refresh your session.
You switched accounts on another tab or window.
Reload
to refresh your session.
Dismiss alert
{{ message }}
bcgit
bc-csharp
Repository navigation
Code
Issues
117
(117)
Pull requests
39
(39)
Discussions
Actions
Projects
Wiki
Security and quality
Insights
More
items
All pull requests
Labels
10
(10)
Milestones
0
(0)
New pull request
Search pull requests
is
:
pr
state
:
open
is:pr state:open
Clear filter
Search
Pull requests
Open
39
(39)
Closed
176
(176)
Author
Label
Projects
Milestones
Reviews
Assignee
Sort by
Newest
descending
Sort…
Sort by Newest descending
More items
Comfortable display density
Compact display density
Add XML documentation for CMS
#729
·
KonradSop
opened
Oct 27, 2026
Contributor
·
2 of 3 tasks
·
·
Add XML documentation for ASN.1
#728
·
KonradSop
opened
Oct 27, 2026
Contributor
·
2 of 3 tasks
·
·
Add XML documentation for crypto (engines, digests, modes, signers, ...)
#727
·
KonradSop
opened
Oct 27, 2026
Contributor
·
2 of 3 tasks
·
·
Add XML documentation for TLS/DTLS
#726
·
KonradSop
opened
Oct 27, 2026
Contributor
·
2 of 3 tasks
·
·
Add XML documentation for post-quantum (pqc, excluding ntru/hqc/cmce/crystals)
#725
·
KonradSop
opened
Oct 27, 2026
Contributor
·
2 of 3 tasks
·
·
Add XML documentation for util (I/O, encoders, zlib, bzip2)
#724
·
KonradSop
opened
Oct 27, 2026
Contributor
·
2 of 3 tasks
·
·
Add XML documentation for OpenPGP and BCPG
#723
·
KonradSop
opened
Oct 27, 2026
Contributor
·
2 of 3 tasks
·
·
Add XML documentation for math (BigInteger, EC, RFC 7748/8032)
#722
·
KonradSop
opened
Oct 27, 2026
Contributor
·
2 of 3 tasks
·
·
Add XML documentation for X.509 and security utilities
#721
·
KonradSop
opened
Oct 27, 2026
Contributor
·
2 of 3 tasks
·
·
Add XML documentation for CMP and CRMF
#720
·
KonradSop
opened
Oct 27, 2026
Contributor
·
2 of 3 tasks
·
·
Add XML documentation for PKCS and OpenSSL
#719
·
KonradSop
opened
Oct 27, 2026
Contributor
·
2 of 3 tasks
·
·
Add XML documentation for PKIX
#718
·
KonradSop
opened
Oct 27, 2026
Contributor
·
2 of 3 tasks
·
·
Add XML documentation for TSP
#717
·
KonradSop
opened
Oct 27, 2026
Contributor
·
2 of 3 tasks
·
·
Add XML documentation for OCSP
#716
·
KonradSop
opened
Oct 27, 2026
Contributor
·
2 of 3 tasks
·
·
Add RFC 9580 version 6 and RFC 9980 post-quantum OpenPGP
#715
·
rosen-vl
opened
Oct 26, 2026
·
3 tasks done
·
·
Replace heap-allocated temporary byte arrays with
ArrayPool<byte>.Shared
rentals in
CipherStream
and
Streams
to reduce GC pressure on hot I/O paths
#664
·
paulomorgado
opened
Mar 5, 2026
Contributor
·
2 of 3 tasks
·
·
5
SRP message verification using RFC2945
#659
·
jimm98y
opened
Jan 5, 2026
·
3 tasks done
·
·
1
Allows creation of HashMLDsaSigner that can sign hashes
#655
·
harrison314
opened
Nov 29, 2025
Contributor
·
2 of 3 tasks
·
·
3
Fixes Zlib compression issues.
#648
·
GitHubProUser67
opened
Sep 15, 2025
·
1 task
·
·
2
Update Target Frameworks
#610
·
uniblab
opened
May 5, 2025
Contributor
·
2 of 3 tasks
·
·
Added netstandard2.1 to the build targets
#586
·
jstedfast
opened
Dec 20, 2024
Contributor
·
2 of 3 tasks
·
·
Reference System.Memory and use it in math/raw
#569
·
Rob-Hague
opened
Oct 6, 2024
Contributor
·
2 of 3 tasks
·
·
4
PQC hybrid key support
#565
·
bencemali
opened
Sep 11, 2024
·
·
2
Fixed BUG、CMS: Add SM3WithSM2、Improve ZUC128 and add ZUC256
#537
·
haozekang
opened
May 16, 2024
·
·
Implement the LIBSECURE Xtea cryptography library.
#531
·
GitHubProUser67
opened
Mar 30, 2024
·
·
Previous
1
2
Next
You can’t perform that action at this time.